vRealize Automation登錄 vRealize Business for Cloud 後,顯示錯誤訊息。

問題

vRealize Automation登錄 vRealize Business for Cloud 後,如果您導覽至管理 > 商業管理,將顯示 java.net.NoRouteToHostException: 無任何到主機的路由錯誤訊息。

原因

如果 vRealize Business for CloudvRealize Automation 登錄後,vRealize Business for Cloud 虛擬應用裝置的 IP 位址發生變更,則會出現此問題。

解決方案

如需有關重新建立 SSL 金鑰存放區的資訊,請參閱安裝指南中的〈變更或取代 vRealize Business for Cloud的 SSL 憑證〉一節。

如需有關如何登錄 vRealize Business for Cloud的資訊,請參閱安裝指南中的〈向 vRealize Automation 登錄 vRealize Business for Cloud一節。

程序

  1. 解除登錄 vRealize Business for Cloud
    1. 登入 vRealize Business for Cloud Web 主控台,網址為 https:// vRealize_Business_for_Cloud_IP_address:5480。
    2. 根據您的登錄設定,執行適用的步驟。

      選項

      程序

      如果您已向 vRealize Automation 登錄

      1. 下載所有 vRealize Automation 報告。如需更多資訊,請參閱 https://kb.vmware.com/s/article/2151835

      2. 登錄索引標籤上,按一下 vRealize Automation

      3. 輸入已登錄的 vRealize Automation 伺服器的詳細資料。

      4. 按一下解除登錄

      如果所有參數都正確,您會看到已向 vRealize Automation 伺服器解除登錄訊息。

      如果您已向 VMware Identity Manager 登錄

      1. 登錄索引標籤上,按一下 vIDM

      2. 輸入已登錄的 VMware Identity Manager 虛擬應用裝置的詳細資料。

      3. 按一下解除登錄

      如果所有參數都正確,您會看到已向 vIDM 解除登錄訊息。

  2. 執行下列其中一個步驟。
    • 從您的環境中移除 vRealize Business for Cloud虛擬應用裝置,並使用靜態 IP 和完整網域名稱部署 vRealize Business for Cloud 的新執行個體。

    • 重新建立 SSL 金鑰儲存區檔案 (ssl.keystore)。

  3. vRealize Automation登錄 vRealize Business for Cloud