Como uma área de trabalho VDI flutuante é baseada em uma imagem de vários pods na qual o App Volumes Agent está instalado e os usuários finais que têm direito ao aplicativos do App Volumes fazem login na área de trabalho, eles veem uma mensagem de erro que contém a frase "A virtualização está desativada".
Problema
Ao ser feito login na área de trabalho VDI flutuante, uma mensagem de erro é exibida, semelhante a "Erro de conexão. Não é possível entrar em contato com o App Volumes Manager. A virtualização está desativada." ou "Erro do Gerenciador (código de erro: 400) A virtualização está desativada."
Causa
Esse problema ocorre no cenário a seguir.
- Você tem vários pods do Horizon Cloud on Microsoft Azure na frota do tenant.
- Os desktops VDI flutuantes foram criados usando imagens de vários pods usando o fluxo de trabalho de publicação na página do console.
- No fluxo de trabalho de publicação, a opção Instalar Horizon Agent foi desativada. Ou seja, a opção de fazer com que o Serviço de Gerenciamento de Imagens instale o agente durante o fluxo de trabalho de publicação foi desmarcada.
Por design no Horizon Cloud Service de primeira geração, cada pod tem seu próprio endereço IP do App Volumes Manager.
No fluxo de trabalho de publicação de uma imagem de vários pods uma cópia é publicada em cada pod de destino.
A cópia de cada pod da imagem de vários pods deve conhecer o IP do App Volumes Manager específico para esse pod.
A maneira como cada cópia conhece o IP do App Volumes Manager de seu pod associado é quando o Image Management Service (IMS) instala o Horizon Agent.
Somente quando a opção Instalar Horizon Agent estiver ativada para o fluxo de trabalho Publicar, o IMS executará suas ações projetadas para configurar cada cópia com o IP do App Volumes Manager específico do seu pod.
Se a opção Instalar o Horizon Agent estiver desativada no fluxo de trabalho Publicar, o IMS ignorará essas ações, o que fará com que todas as cópias terminem sendo configuradas com o mesmo IP do App Volumes Manager, em vez dos IPs individuais específicos de seus pods.
Portanto, para evitar esse problema, faça com que o IMS realize a instalação do agente como parte de seu fluxo de trabalho Publicar. Verifique se a opção Instalar Horizon Agent está ativada no fluxo de trabalho Publicar.
Solução
- Para corrigir esse problema para áreas de trabalho existentes e imagens de vários pods publicadas
-
- Localize a imagem na página Imagens: Vários Pods do console (
- Clique no nome da imagem para navegar até a página da UI das versões da imagem.
Clique no nome da imagem, conforme ilustrado pela seta verde na captura de tela anterior.
Em seguida, na página de versões da imagem, clique no botão de opção para que a ação Nova Versão fique disponível.
- Clique em Nova Versão para criar uma nova versão da imagem.
Você publicará essa nova versão com a opção de instalar o Horizon Agent nesta nova versão da imagem.
A captura de tela a seguir ilustra a UI após a seleção de Nova Versão e o preenchimento das informações.
Importante: Lembre-se de inserir um marcador e clicar em Digitar para garantir que o marcador seja exibido no campo Marcadores antes de enviar essa janela. Este um marcador não existir para a versão, você não poderá concluir com êxito a etapa final de atualização da atribuição de área de trabalho VDI flutuante para usar essa nova versão da imagem.Clique em Enviar para concluir a criação dessa nova versão da imagem.
O sistema implantará a VM subjacente para a nova versão da imagem.
- Quando a UI indicar a nova versão da imagem com o status Implantação Concluída na página de versões da imagem, selecione essa versão da imagem e clique em Publicar.
- No fluxo de trabalho Publicar, certifique-se de que a opção Instalar Horizon Agent esteja ativada.
Atenção: É essencial garantir que a opção Instalar Horizon Agent esteja ativada para essa nova versão de imagem. Isso garante que o problema de virtualização desativada não ocorra quando você concluir essas etapas de solução de problemas.
- Depois atualize a atribuição de área de trabalho VDI flutuante para usar a nova versão da imagem quando a versão estiver pronta.
- Localize a imagem na página Imagens: Vários Pods do console (
- Para evitar esse problema em novas imagens
- Sempre use o fluxo de trabalho Importar Imagem na página Imagens: Vários Pods do console e publique as imagens usando o fluxo de trabalho padrão, com Instalar Horizon Agent ativado.