Como uma área de trabalho VDI flutuante é baseada em uma imagem de vários pods na qual o App Volumes Agent está instalado e os usuários finais que têm direito ao aplicativos do App Volumes fazem login na área de trabalho, eles veem uma mensagem de erro que contém a frase "A virtualização está desativada".

Problema

Ao ser feito login na área de trabalho VDI flutuante, uma mensagem de erro é exibida, semelhante a "Erro de conexão. Não é possível entrar em contato com o App Volumes Manager. A virtualização está desativada." ou "Erro do Gerenciador (código de erro: 400) A virtualização está desativada."

Observação: O App Volumes usado com implantações do Horizon Cloud on Microsoft Azure só tem suporte para uso com áreas de trabalho VDI flutuantes. Como as áreas de trabalho VDI dedicadas não têm suporte atualmente para uso com o App Volumes com esses pods do Horizon Cloud, essa página de documentação descreve o cenário de áreas de trabalho VDI flutuantes.

Causa

Esse problema ocorre no cenário a seguir.

  • Você tem vários pods do Horizon Cloud on Microsoft Azure na frota do tenant.
  • Os desktops VDI flutuantes foram criados usando imagens de vários pods usando o fluxo de trabalho de publicação na página Inventário > Imagens - Vários Pods do console.
  • No fluxo de trabalho de publicação, a opção Instalar Horizon Agent foi desativada. Ou seja, a opção de fazer com que o Serviço de Gerenciamento de Imagens instale o agente durante o fluxo de trabalho de publicação foi desmarcada.

Por design no Horizon Cloud Service de primeira geração, cada pod tem seu próprio endereço IP do App Volumes Manager.

No fluxo de trabalho de publicação de uma imagem de vários pods uma cópia é publicada em cada pod de destino.

A cópia de cada pod da imagem de vários pods deve conhecer o IP do App Volumes Manager específico para esse pod.

A maneira como cada cópia conhece o IP do App Volumes Manager de seu pod associado é quando o Image Management Service (IMS) instala o Horizon Agent.

Somente quando a opção Instalar Horizon Agent estiver ativada para o fluxo de trabalho Publicar, o IMS executará suas ações projetadas para configurar cada cópia com o IP do App Volumes Manager específico do seu pod.

Se a opção Instalar o Horizon Agent estiver desativada no fluxo de trabalho Publicar, o IMS ignorará essas ações, o que fará com que todas as cópias terminem sendo configuradas com o mesmo IP do App Volumes Manager, em vez dos IPs individuais específicos de seus pods.

Portanto, para evitar esse problema, faça com que o IMS realize a instalação do agente como parte de seu fluxo de trabalho Publicar. Verifique se a opção Instalar Horizon Agent está ativada no fluxo de trabalho Publicar.

Observação: Esse problema também ocorre quando você criou a imagem publicada usando a ação Mover para Imagens de Vários Pods, que move uma imagem importada da página VMs importadas do console para a página Imagens: vários pods e, em seguida, publica a primeira versão da imagem e usa essa imagem nas atribuições da área de trabalho. No caso de uso da ação Mover para Imagens de Vários Pods, o console não disponibiliza a opção Instalar Horizon Agent para ativação porque a imagem das VMs importadas já tem o agente instalado. Para obter uma solução alternativa para esse cenário específico, use a primeira solução abaixo.

Solução

Para corrigir esse problema para áreas de trabalho existentes e imagens de vários pods publicadas
  1. Localize a imagem na página Imagens: Vários Pods do console (Inventário > Imagens: Vários Pods).
    Captura de tela da imagem na página Imagens de Vários Pods com uma seta verde apontando para o local em que é necessário clicar.
  2. Clique no nome da imagem para navegar até a página da UI das versões da imagem.

    Clique no nome da imagem, conforme ilustrado pela seta verde na captura de tela anterior.

    Em seguida, na página de versões da imagem, clique no botão de opção para que a ação Nova Versão fique disponível.


    Captura de tela da página de versões da imagem com setas verdes indicando o botão para selecioná-la e o botão Nova Versão.
  3. Clique em Nova Versão para criar uma nova versão da imagem.

    Você publicará essa nova versão com a opção de instalar o Horizon Agent nesta nova versão da imagem.

    A captura de tela a seguir ilustra a UI após a seleção de Nova Versão e o preenchimento das informações.

    Importante: Lembre-se de inserir um marcador e clicar em Digitar para garantir que o marcador seja exibido no campo Marcadores antes de enviar essa janela. Este um marcador não existir para a versão, você não poderá concluir com êxito a etapa final de atualização da atribuição de área de trabalho VDI flutuante para usar essa nova versão da imagem.

    Captura de tela da UI de Nova Versão preenchida e pronta para envio.

    Clique em Enviar para concluir a criação dessa nova versão da imagem.

    O sistema implantará a VM subjacente para a nova versão da imagem.

  4. Quando a UI indicar a nova versão da imagem com o status Implantação Concluída na página de versões da imagem, selecione essa versão da imagem e clique em Publicar.
    Captura de tela da nova versão selecionada e da ação Publicar com setas verdes apontando para ambas.
  5. No fluxo de trabalho Publicar, certifique-se de que a opção Instalar Horizon Agent esteja ativada.
    Atenção: É essencial garantir que a opção Instalar Horizon Agent esteja ativada para essa nova versão de imagem. Isso garante que o problema de virtualização desativada não ocorra quando você concluir essas etapas de solução de problemas.
  6. Depois atualize a atribuição de área de trabalho VDI flutuante para usar a nova versão da imagem quando a versão estiver pronta.
Para evitar esse problema em novas imagens
Sempre use o fluxo de trabalho Importar Imagem na página Imagens: Vários Pods do console e publique as imagens usando o fluxo de trabalho padrão, com Instalar Horizon Agent ativado.