VMware Identity Manager 中不显示 Citrix 授权。
问题
在 Citrix 服务器上设置了对应用程序或交付组的授权,但是 VMware Identity Manager 中不会显示这些授权。
原因
有权访问应用程序或交付组的用户和组可能未同步到 VMware Identity Manager。
解决方案
确保已将用户和组同步到 VMware Identity Manager。
登录到 Citrix 管理控制台,然后找到没有任何授权的应用程序。
记下 Citrix 管理控制台中有权启动该应用程序的 Active Directory 用户和组。
登录到 VMware Identity Manager 管理控制台,单击用户和组选项卡,然后验证列表中是否显示了这些用户和组。
您也可以使用页面右上方的搜索框。
如果显示了这些用户和组,请从目录 > 管理桌面应用程序 > Citrix 发布的应用程序页面中再次同步 Citrix 资源。
注:在同步 Citrix 资源之前,VMware Identity Manager 中必须存在这些用户和组。如果不存在,同步也将运行,但是不会更新授权。
如果 VMware Identity Manager 中不存在这些用户和组,请执行以下操作。
检查这些用户和组在 Active Directory 中的位置(使用 Active Directory 用户和计算机管理单元)。
在 VMware Identity Manager 管理控制台中,在目录的同步设置页面中更新这些用户和组的 AD 同步 DN。
当 VMware Identity Manager 管理控制台中显示这些用户和组时,再次同步 Citrix 资源。
同步完成后,VMware Identity Manager 中即会显示相应授权。