Das Upgrade eines vorhandenen Cloud-Proxys für die Verwendung mit einem VMware Aria Automation-Cloud-Konto schlägt mit einem Manifestzugriffsfehler fehl.

Problem

Sie können einen vorhandenen konfigurierten Cloud-Proxy aktualisieren, anstatt einen neuen Cloud-Proxy für ein vorhandenes oder neues VMware Aria Automation-Cloud-Konto zu erstellen und zu konfigurieren. Das Upgrade kann jedoch mit folgender oder einer ähnlichen Fehlermeldung fehlschlagen.
Details
Checking for available updates, this process can take a few minutes ...
Failure: Error downloading manifest. Please contact your vendor.  
The requested URL returned error: 404 Not Found URL: <https:// ...>

Ursache

In der Manifestdatei /opt/vmware/var/lib/vami/update/provider/provider-runtime.xml, die beim Konfigurieren des Cloud-Proxys verwendet wurde, fehlen unter Umständen bestimmte während des Upgrades benötigte Informationen.
Hinweis: Dieses Problem mit der Manifestdatei wurde in neueren Versionen von VMware Aria Automation behoben. Wenn Sie jedoch einen älteren Cloud-Proxy verwenden und die angegebene Fehlermeldung erhalten, verwenden Sie diese Problemumgehung zum Aktualisieren der Manifestdatei provider-runtime.xml des Cloud-Proxys.

Lösung

  1. Suchen Sie nach der Manifestdatei des Cloud-Proxys und überprüfen Sie sie. Ein Beispiel /opt/vmware/var/lib/vami/update/provider/provider-runtime.xml wird unten angezeigt:
    <service>
      <properties>
         <property name="jobId" value="1" />_
         <property name="jobList" value='{ "Check":{ "JobStatus": "Failed", "JobState": 8, "TimeOfLastStateChange": "20210120101111.982008+000", "ErrorCode": 20, "ErrorDescription": "Error downloading manifest. Please contact your vendor. The requested URL returned error: 404 Not Found URL: https:\/\/vapp-updates.vmware.com\/vai-catalog\/valm\/vmw\/a1ba78af-ec67-4333-8e25-a4be022f97c7\/7.2.0.33184.latest\/manifest\/manifest-latest.xml", "TimeBeforeRemoval": "00000000000500.000000:000", "TimeSubmitted": "20210120101031.385064+000", "InstanceID": "VMware-VAMI:Job_1" }}' />_
      </properties>
    </service>
  2. Wenn die Datei Inhalte ähnlich den obigen enthält, aktualisieren Sie die Datei manuell mit folgendem Inhalt:
    <service>
        <properties>
            <property name="localRepositoryAddress" value="https://ci-data-collector-sandbox.s3.amazonaws.com/upgrade" />
            <property name="localRepositoryPasswordFormat" value="base64" />
        </properties>
    </service>
  3. Starten Sie den Cloud-Proxy auf dem vCenter neu.
  4. Führen Sie dasselbe Cloud-Proxy-Upgrade aus, das Sie zuvor ausgeführt haben und das den oben genannten Fehler verursacht hat.
  5. Wenn der Fehler weiterhin besteht, wenden Sie sich an VMware Support.