Wenn ein flexibler VDI-Desktop auf einem Multi-Pod-Image basiert, in dem App Volumes Agent installiert ist, und sich die Endbenutzer, die für die App Volumes-Anwendungen berechtigt sind, beim Desktop anmelden, wird eine Fehlermeldung mit dem Satz „Virtualisierung wird deaktiviert“ angezeigt.
Problem
Bei der Anmeldung am flexiblen VDI-Desktop wird eine Fehlermeldung angezeigt, die in etwa so lautet: „Verbindungsfehler. App Volumes Manager konnte nicht kontaktiert werden. Virtualisierung wird deaktiviert.“ oder „Fehler vom Manager (Fehlercode: 400) Virtualisierung wird deaktiviert.“
Ursache
Dieses Problem tritt im folgenden Szenario auf.
- Sie haben mehrere Horizon Cloud on Microsoft Azure-Pods in der Flotte Ihres Mandanten.
- Die flexiblen VDI-Desktops wurden mit Multi-Pod-Images mithilfe des Veröffentlichungsworkflows auf der Seite der Konsole erstellt.
- Im Veröffentlichungsworkflow wurde die Umschaltoption Horizon Agent installieren deaktiviert. Das heißt, die Option zum Installieren des Agents durch den Image-Verwaltungsdienst während des Veröffentlichungsworkflows wurde deaktiviert.
Beim First-Generation-Horizon Cloud Service verfügt jeder Pod über eine eigene App Volumes Manager-IP-Adresse.
Im Veröffentlichungsworkflow eines Multi-Pod-Images wird eine Kopie für jeden Ziel-Pod veröffentlicht.
Die Kopie des Multi-Pod-Images eines jeden Pods muss die spezifische App Volumes Manager-IP für diesen Pod kennen.
Jede Kopie erfährt die App Volumes Manager-IP für den zugehörigen Pod, wenn der Image-Verwaltungsdienst (IMS) den Horizon Agent installiert.
Nur wenn die Umschaltoption Horizon Agent installieren für den Veröffentlichungsworkflow aktiviert ist, führt IMS die vorgesehenen Aktionen aus, um jede Kopie mit der spezifischen App Volumes Manager-IP des Pods zu konfigurieren.
Wenn die Umschaltoption Horizon Agent installieren im Veröffentlichungsworkflow ausgeschaltet ist, überspringt IMS diese Aktionen, was dazu führt, dass alle Kopien mit derselben App Volumes Manager-IP konfiguriert werden, anstatt mit den individuellen IPs, die für ihre Pods spezifisch sind.
Um dieses Problem zu vermeiden, lassen Sie IMS die Agent-Installation im Rahmen des Veröffentlichungsworkflows durchführen. Stellen Sie sicher, dass die Umschaltoption Horizon Agent installieren im Veröffentlichungsworkflow aktiviert ist.
Lösung
- So beheben Sie dieses Problem für vorhandene Desktops und veröffentlichte Multi-Pod-Images
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- Suchen Sie das Image auf der Seite „Images – Multi-Pod“ der Konsole (
- Klicken Sie auf den Namen des Images, um die Seite mit der Darstellung der Benutzeroberfläche für die Image-Versionen aufzurufen.
Klicken Sie auf den Namen des Images, wie der grüne Pfeil im vorherigen Screenshot zeigt.
Klicken Sie dann auf dieser Seite mit den Image-Versionen auf das Optionsfeld, damit die Aktion Neue Version verfügbar wird.
- Klicken Sie auf Neue Version, um eine neue Version des Images zu erstellen.
Sie veröffentlichen diese neue Version mit der Option zum Installieren des Horizon Agent in dieser neuen Image-Version.
Der folgende Screenshot veranschaulicht die Benutzeroberfläche, nachdem Sie auf Neue Version geklickt und die Informationen ausgefüllt haben.
Wichtig: Denken Sie daran, eine Markierung einzugeben und auf Eingabe zu klicken, um sicherzustellen, dass die Markierung im Feld Marker angezeigt wird, bevor Sie dieses Fenster absenden. Wenn für die Version keine Markierung vorhanden ist, können Sie den letzten Schritt der Aktualisierung der schwebenden VDI-Desktop-Zuweisung zur Verwendung dieser neuen Image-Version nicht erfolgreich abschließen.Klicken Sie auf Absenden, um die Erstellung dieser neuen Image-Version abzuschließen.
Das System stellt die zugrunde liegende VM für die neue Version bereit.
- Wenn die Benutzeroberfläche für die neue Version Bereitstellung abgeschlossen auf der Seite mit den Image-Versionen anzeigt, wählen Sie die neue Version aus und klicken Sie auf Veröffentlichen.
- Vergewissern Sie sich, dass im Workflow „Veröffentlichen“ die Option Horizon Agent installieren aktiviert ist.
Achtung: Stellen Sie sicher, dass die Option Horizon Agent installieren für diese neue Image-Version aktiviert ist, um zu gewährleisten, dass das Problem „Virtualisierung ist deaktiviert“ nicht auftritt, wenn Sie diese Schritte zur Fehlerbehebung durchführen.
- Aktualisieren Sie dann die Zuweisung des flexiblen VDI-Desktops, um die neue Image-Version zu verwenden, wenn sie bereit ist.
- Suchen Sie das Image auf der Seite „Images – Multi-Pod“ der Konsole (
- So vermeiden Sie dieses Problem bei brandneuen Images
- Verwenden Sie immer den Workflow Image importieren auf der Seite Images – Multi-Pod der Konsole und veröffentlichen Sie die Images mithilfe des Standardworkflows, wobei die Option Horizon Agent installieren aktiviert ist.