Wenn Sie versuchen, ein Unmounten oder Entfernen eines Datenspeichers durchzuführen, schlägt der Vorgang fehl.

Problem

Das Unmounten oder Entfernen eines Datenspeichers schlägt fehl, wenn im Datenspeicher geöffnete Dateien vorhanden sind. Für diese Benutzervorgänge schließt der vSphere HA-Agent alle Dateien, die er geöffnet hat, beispielsweise die Taktsignal-Dateien. Falls der Agent nicht von vCenter Server erreicht werden kann oder der Agent ausstehende E/A-Vorgänge nicht auf die Festplatte schreiben kann, um die Dateien zu schließen, wird der Fehler Der vSphere HA-Agent auf Host '{hostName}' konnte die Dateiaktivitäten auf dem Datenspeicher '{dsName}' nicht stilllegen ausgelöst.

Ursache

Wenn der Datenspeicher, für den ein Unmounten durchgeführt oder der entfernt werden soll, für Taktsignale verwendet wird, schließt vCenter Server ihn als Taktsignal-Datenspeicher aus und wählt dafür einen neuen Datenspeicher aus. Allerdings empfängt der Agent nicht die aktualisierten Taktsignal-Datenspeicher, wenn er nicht erreichbar ist. Dies ist der Fall, wenn der Host isoliert ist oder sich in einer Netzwerkpartition befindet. In diesen Fällen werden die Taktsignal-Dateien nicht geschlossen und der Benutzervorgang schlägt fehl. Der Vorgang kann auch fehlschlagen, wenn der Datenspeicher aufgrund von Speicherausfällen, z. B. „Keine Pfade verfügbar“, nicht zugänglich ist.

Hinweis: Wenn Sie einen VMFS-Datenspeicher entfernen, wird der Datenspeicher von allen Hosts in der Bestandsliste entfernt. Wenn also Hosts in einem vSphere HA-Cluster nicht erreichbar sind oder Hosts nicht auf den Datenspeicher zugreifen können, schlägt der Vorgang fehl.

Lösung

Stellen Sie sicher, dass der Datenspeicher zugänglich ist und die betreffenden Hosts erreichbar sind.