Wenn Sie eine virtuelle Maschine erstellen oder eine vorhandene virtuelle Maschine aktualisieren, verwenden Sie die Kompatibilitätseinstellung der virtuellen Maschine, um die ESXi-Host-Versionen auszuwählen, auf denen die virtuelle Maschine laufen soll.

Die Einstellung für die Kompatibilität legt die virtuelle Hardware fest, die für die virtuelle Maschine verfügbar ist. Dies entspricht der physischen Hardware, die auf dem Host zur Verfügung steht. Die virtuelle Hardware umfasst das BIOS und EFI, die verfügbaren virtuellen PCI-Steckplätze, die maximale Anzahl an CPUs, den Maximalwert für die Arbeitsspeicherkonfiguration und weitere Eigenschaften. Neue Fähigkeiten der virtuellen Hardware werden in der Regel einmal jährlich mit Haupt- und Nebenversionen von vSphere veröffentlicht.

Jede Kompatibilitätsebene einer virtuellen Maschine unterstützt mindestens fünf Haupt- und Nebenversionen von vSphere. Beispielsweise kann eine virtuelle Maschine, die mit ESXi 6.5 und höher kompatibel ist, unter ESXi 6.7, ESXi 6.7 Update 2, ESXi 7.0, ESXi 7.0 Update 1, ESXi 7.0 Update 2, ESXi 7.0 Update 3 und ESXi 8.0 ausgeführt werden.

Tabelle 1. Kompatibilitätsoptionen für virtuelle Maschinen
Kompatibilität Beschreibung
ESXi 8.0 und höher Diese virtuelle Maschine (Hardwareversion 20) ist mit VMware ESXi 8.0 und höher kompatibel.
ESXi 7.0 Update 3 und höher Diese virtuelle Maschine (Hardwareversion 19) ist mit ESXi 7.0 Update 3 und ESXi 8.0 kompatibel.
ESXi 7.0 Update 2 und höher Diese virtuelle Maschine (Hardwareversion 19) ist kompatibel mit ESXi 7.0 Update 2, ESXi 7.0 Update 3 und ESXi 8.0.
ESXi 7.0 Update 1 und höher Diese virtuelle Maschine (Hardwareversion 18) ist kompatibel mit ESXi 7.0 Update 1, ESXi 7.0 Update 2 und ESXi 7.0 Update 3 und ESXi 8.0.
ESXi 7.0 und höher Diese virtuelle Maschine (Hardwareversion 17) ist kompatibel mit ESXi 7.0, ESXi 7.0 Update 1, ESXi 7.0 Update 2 und ESXi 7.0 Update 3 und ESXi 8.0.
ESXi 6.7 Update 2 und höher Diese virtuelle Maschine (Hardwareversion 15) ist kompatibel mit ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, ESXi 7.0 Update 1, ESXi 7.0 Update 2, ESXi 7.0 Update 3 und ESXi 8.0.
ESXi 6.7 und höher Diese virtuelle Maschine (Hardwareversion 14) ist kompatibel mit ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, ESXi 7.0 Update 1, ESXi 7.0 Update 2, ESXi 7.0 Update 3 und ESXi 8.0.
ESXi 6.5 und höher Diese virtuelle Maschine (Hardwareversion 13) ist kompatibel mit ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0, ESXi 7.0 Update 1, ESXi 7.0 Update 2, ESXi 7.0 Update 3 und ESXi 8.0.

Die Kompatibilitätseinstellung, die im Dropdown-Menü Kompatibel mit angezeigt wird, ist der Standard für die virtuelle Maschine, die Sie erstellen. Folgende Faktoren bestimmen die Standardkompatibilität der virtuellen Maschine:

  • Die Version des ESXi-Hosts, auf dem die virtuelle Maschine erstellt wird.
  • Das Bestandslistenobjekt, auf das die Standardkompatibilität der virtuellen Maschine eingestellt ist, einschließlich einem Host, Cluster oder Datencenter.

Sie können die Standardkompatibilität akzeptieren oder eine vom Standard abweichende Kompatibilität auswählen. Es ist nicht immer notwendig, die neueste Version des ESXi-Hosts auszuwählen. Die Wahl einer älteren Version kann größere Flexibilität bringen und ist in folgenden Situationen nützlich:

  • Zum Standardisieren von Tests und der Bereitstellung in Ihrer virtuellen Umgebung.
  • Wenn Sie die Funktionen der neuesten Host-Version nicht benötigen.
  • Um Kompatibilität mit älteren Hosts beizubehalten.

Wenn Sie eine virtuelle Maschine erstellen, berücksichtigen Sie die Ausführungsumgebung der VM und wägen Sie die Vorteile unterschiedlicher Kompatibilitätsstrategien gegeneinander ab. Überlegen Sie sich Ihre Optionen für jene Szenarios, die mit jeder Auswahl die für die VM-Kompatibilität eigene Flexibilität veranschaulichen.

Objekte in der Umgebung Kompatibilität Ergebnisse
Cluster mit ESXi 6.5-, ESXi 6.7-, ESXi 7.0-, ESXi 7.0 Update 1-, ESXi 7.0 Update 2-, ESXi 7.0 Update 3- und ESXi 8.0-Hosts

ESXi 6.5 und höher

Diese virtuelle Maschine verfügt nicht über alle Funktionen, die virtuellen Maschinen zur Verfügung stehen, die auf ESXi 6.7 und höher ausgeführt werden.

Cluster mit ESXi 6.5-, ESXi 6.7-, ESXi 7.0-, ESXi 7.0 Update 1-, ESXi 7.0 Update 2-, ESXi 7.0 Update 3- und ESXi 8.0-Hosts

ESXi 6.7 und höher

Diese virtuelle Maschine verfügt nicht über alle Funktionen, die virtuellen Maschinen zur Verfügung stehen, die auf ESXi 7.0 und höher ausgeführt werden. Eine virtuelle Maschine mit einer solchen Kompatibilität kann nicht unter ESXi 6.5 ausgeführt werden.

Cluster mit ESXi 6.5-, ESXi 6.7-, ESXi 7.0-, ESXi 7.0 Update 1-, ESXi 7.0 Update 2-, ESXi 7.0 Update 3- und ESXi 8.0-Hosts

ESXi 7.0 und höher

Diese virtuelle Maschine verfügt nicht über alle Funktionen, die virtuellen Maschinen zur Verfügung stehen, die auf ESXi 7.0 Update 1 und höher ausgeführt werden. Eine virtuelle Maschine mit einer solchen Kompatibilität kann nicht unter ESXi 6.7 und früher ausgeführt werden.

Cluster mit ESXi 6.5-, ESXi 6.7-, ESXi 7.0-, ESXi 7.0 Update 1-, ESXi 7.0 Update 2-, ESXi 7.0 Update 3- und ESXi 8.0-Hosts

ESXi 7.0 Update 1 und höher

Diese virtuelle Maschine verfügt nicht über alle Funktionen, die virtuellen Maschinen zur Verfügung stehen, die auf ESXi 7.0 Update 2 und höher ausgeführt werden. Eine virtuelle Maschine mit einer solchen Kompatibilität kann nicht unter ESXi 7.0 und früher ausgeführt werden.

Cluster mit ESXi 6.5-, ESXi 6.7-, ESXi 7.0-, ESXi 7.0 Update 1-, ESXi 7.0 Update 2-, ESXi 7.0 Update 3- und ESXi 8.0-Hosts

ESXi 7.0 Update 2 und höher

Diese virtuelle Maschine verfügt nicht über alle Funktionen, die virtuellen Maschinen zur Verfügung stehen, die auf ESXi 7.0 Update 3 und höher ausgeführt werden. Eine virtuelle Maschine mit einer solchen Kompatibilität kann nicht unter ESXi 7.0 Update 1 und früher ausgeführt werden.

Cluster mit ESXi 6.5-, ESXi 6.7-, ESXi 7.0-, ESXi 7.0 Update 1-, ESXi 7.0 Update 2-, ESXi 7.0 Update 3- und ESXi 8.0-Hosts

ESXi 7.0 Update 3 und höher

Diese virtuelle Maschine verfügt nicht über alle Funktionen, die virtuellen Maschinen zur Verfügung stehen, die auf ESXi 8.0 und höher ausgeführt werden. Eine virtuelle Maschine mit einer solchen Kompatibilität kann nicht unter ESXi 7.0 Update 2 und früher ausgeführt werden.

Cluster mit ESXi 6.5-, ESXi 6.7-, ESXi 7.0-, ESXi 7.0 Update 1-, ESXi 7.0 Update 2-, ESXi 7.0 Update 3- und ESXi 8.0-Hosts ESXi 8.0 und höher

Dadurch wird der Zugriff auf die neuesten virtuellen Hardwarefunktionen ermöglicht und eine optimale Leistung gewährleistet. Eine virtuelle Maschine mit einer solchen Kompatibilität kann jedoch nicht unter ESXi 6.5, ESXi 6.7, ESXi 7.0, ESXi 7.0 Update 1, ESXi 7.0 Update 2 oder v 7.0 Update 3 ausgeführt werden.

Informationen zur Verwaltung der Kompatibilität virtueller Maschinen finden Sie in der Dokumentation vSphere-Administratorhandbuch für virtuelle Maschinen.