When using App Links, if an end user experiences an error, use the information present in this section to understand and troubleshoot the error.

For more information about App Links, see Launch an App Volumes Application with an App Link.

The requested application is not assigned to you. Please contact your administrator.

This error message occurs when the end user has invoked an App Link to launch the application but the App Volumes application is not assigned to the user.

Problem

Application is not assigned to the end user.

Cause

This error can occur due to the following reasons:
  • There might be a copy-paste error when using the URI.
  • End user is not assigned the application, hence package is not delivered to the user.

Solution

To resolve this error, you can try one of these solutions:

  • Ensure that the end user uses the correct URI.
  • Ensure that the user is assigned the application.

The application resource to launch was not found. Please contact your administrator.

This error message occurs when the end user has invoked an App Link to launch the App Volumes application but the Launch ID in the App Link is invalid.

Problem

Launch ID in the App Link is invalid.

If the App Link has a valid application GUID but an invalid Launch ID, then the application is still delivered to the end user. However, the user cannot launch the application using the App Link as the Launch ID is invalid. After the application is delivered, the user can use alternate methods to launch the application such as shortcuts from the Start menu or the programs' executable.

Cause

This error can occur due to the following reasons:
  • There might be a copy-paste error when using the URI.
  • End user uses an outdated App Link.
    An App Link can be outdated due to the following:
    • Package is updated but the user uses the App Link from the previous version of the package.
    • Package is deleted.

Solution

To resolve this error, you can try one of these solutions:

  • Ensure that the end user uses the correct URI.
  • Ensure that the end user has the App Link of the updated package.
  • Ensure that the correct application package is assigned to the user.

The requested application is not assigned to you. Please contact your administrator.

This error message occurs when the end user has invoked an App Link to launch the App Volumes application but the application GUID in the App Link is not valid.

Problem

Application product GUID is invalid hence the application is not delivered to the end user.

Cause

This error can occur due to the following reasons:
  • There might be a copy-paste error when using the URI.
  • End user uses an outdated App Link.

    An App link can be outdated when an application is deleted.

Solution

To resolve this error, you can try one of these solutions:

  • Ensure that the end user uses the correct URI.
  • Ensure that the correct application is assigned to the user.

Windows Cannot Find the Path to Launch the App Volumes Application

If the launch path is not found due to any reason such as a package update, then the Launch ID in the App Link points to a path which does not exist in the updated package. As a result, a Windows error occurs.

Problem

If an application package does not have the path from which the application can be launched, the App Link becomes outdated. As a result, the following error occurs:

Windows cannot find the path to launch the App Volumes application.

For more information about App Links, see Launch an App Volumes Application with an App Link

Solution

Share the correct App Link with the user. To launch the application, the user must once again invoke the App Link.