Occasionally, when failures in your VMware Data Services Manager environment occur, a VM that has been managed by VMware Data Services Manager might become orphan. The system helps the vSphere administrator identify the orphaned VMs and take appropriate measures.

Problem

An orphaned DSM VM is one that continues to exist in the vCenter Server inventory, but is no longer managed by DSM and does not synchronize with the current state of the DSM infrastructure. These VMs can consume resources and IP addresses, potentially leading to conflicts.

Cause

A DSM VM that backs databases or other objects in the DSM environment might become orphaned when, for example, you recover your environment from a failure. For more information, see Recovering from a Single Provider VM Failure.

In this case, the VM might not get completely deleted and persists in the environment, while it's no longer managed by DSM.

Tags that are automatically assigned to all VMs managed by DSM help the system to detect these orphaned DSM VMs in vCenter Server, and send an alert to DSM administrators.

For more information about the DSM VM tags, see Review Tags Assigned to VMware Data Services Manager VMs.

Solution

  1. As a DSM administrator, check the Orphaned DSM VMs Found alert and identify VM's information.
    Orphaned DSM VMs Found alert as seen by a DSM admin.
  2. As a vSphere administrator, find the identified orphaned DSM VM in the vCenter Server inventory and take appropriate measures.
    If necessary, you can back up its information and then delete the VM to free up resources.