VMware Integrated OpenStack with Kubernetes works together with various products to provide functionality.

VMware Integrated OpenStack with Kubernetes 5.1 requires the following products:

  • VMware Integrated OpenStack 5.0 or 5.1

  • vSphere 6.5 or later

  • (NSX-T deployments) NSX-T 2.2.0 or later

  • (NSX-V deployments) NSX-V 6.3.6 or later

Important:

For NSX-T deployments, ensure that your router can support the desired VMware Integrated OpenStack with Kubernetes configuration. This depends on the NSX Edge node on which the router was created. For information about the resources supported by different NSX Edge node form factors, see Scaling Load Balancer Resources in the NSX-T Data Center Administration Guide for your version of NSX-T.