check-circle-line exclamation-circle-line close-line

VMware Skyline Collector 2.1 Release Notes

Updated on: 28 MAR 2019

VMware Skyline Collector™ 2.1 Release Notes | 28 March 2019

NOTE: These Release Notes do not provide the terms applicable to your license. Consult the VMware Product Guide and VMware End User License Agreement for the license metrics and other license terms applicable to your use of VMware Skyline Collector.

Check for additions and updates to these release notes.

What's in the Release Notes

The release notes cover the following topics:

About VMware Skyline Collector

VMware Skyline™ is a proactive support service aligned with VMware Global Support Services. VMware Skyline automatically and securely collects, aggregates, and analyzes product usage data which proactively identifies potential problems and helps VMware Technical Support Engineers improve time-to-resolution.

This enables richer, more informed interactions between customers and VMware without extensive time investments by Technical Support Engineers. These capabilities transform support operations from reactive, break/fix to a proactive, predictive, and prescriptive experience that produces an even greater return on your VMware support investment.

For more information, see the VMware Skyline Documentation Center.

What's New in this Release

Security Enhancement

With Skyline Collector 2.1.0.0, we introduced explicit TOFU (trust on first use) strategy for outbound connections to configured products (vCenter Server, NSX Manager, etc.). Only Skyline Collectors upgrading from version 1.x will be impacted and customers need to manually re-enter product credentials within the Skyline Collector User Interface. In this scenario, data collection will fail with following message:

The endpoint certificate isn't valid. If the certificate thumbprint has been changed or you have upgraded from a previous version of Skyline, you might need to edit the endpoint in order to re-review and accept the current certificate thumbprint.

Horizon View Proactive Findings Support

Skyline now provides proactive findings and recommendations for Horizon View 7.0 and above. In order to begin receiving proactive findings and recommendations, add a Horizon View Connection Server to Skyline Collector 2.1. Details for how to add a Horizon View Connection Server to Skyline Collector 2.1 can be found in the VMware Skyline Documentation Center.

vRealize Operations Proactive Findings Support

Skyline now provides proactive findings and recommendations for vRealize Operations Manager 6.6, 6.7 and 7.0. In order to begin receiving proactive findings and recommendations for vRealize Operations Manager, add a vRealize Operations Manager to Skyline Collector 2.1. Details for how to add a vRealize Operations Manager to Skyline Collector 2.1 can be found in the VMware Skyline Documentation Center.

Identification of VMware Validated Design (VVD) Deployments

Skyline can now identify if you have deployed a VMware Validated Design (VVD). By identifying VVD deployments, customers and VMware Technical Support can better understand and support multi-product solutions.

Identification of Dell EMC VxRAIL Deployments

Skyline can now identify if you have deployed a Dell EMC VxRAIL Hyper-Converged Infrastructure (HCI). By identifying Dell EMC VxRAIL HCI deployments, customers and VMware Technical Support can better understand and support multi-product solutions.

Compatibility

This section details the supported products for installing the Skyline Collector virtual appliance. The deployment of the Skyline Collector is supported on VMware products and solutions that are Generally Available, and have not met their End of General Support date.

  • VMware vCenter Server: 6.0, 6.5, 6.7
  • VMware ESXi: 6.0, 6.5, 6.7
  • VMware NSX for vSphere: 6.3, 6.4
  • VMware vSAN: 6.0, 6.1, 6.2, 6.5, 6.6, 6.7

Proactive Findings Support

While the deployment of the Skyline Collector is only supported on VMware products and solutions that are Generally Available and have not reached End of General Support, Skyline provides proactive findings and recommendations for the following versions of VMware products and solutions, some of which have passed their End of General Support date. The proactive findings identified for each of the below solutions (if applicable to your environment) can be viewed within Skyline Advisor.

You can add the following versions of VMware products and solutions to the Skyline Collector for the identification of proactive findings and recommendations.

  • VMware vCenter Server: 5.5, 6.0, 6.5, 6.7
  • VMware ESXi: 5.5, 6.0, 6.5, 6.7
  • VMware NSX for vSphere: 6.2, 6.3, 6.4
  • VMware vSAN: 6.0, 6.1, 6.2, 6.5, 6.6, 6.7
  • Horizon View 7: 7.0, 7.1, 7.2, 7.3, 7.4, 7.5, 7.6, 7.7
  • vRealize Operations Manager: 6.6, 6.7, 7.0

For example, Skyline identifies all ESXi 5.5 objects within a vCenter Server and provides additional information from VMware Knowledge Base article 51491, which details the end of general support for vSphere 5.5.

Resolved Issues

The following issues are resolved in this version of Skyline Collector.

  • When using Skyline Log Assist, if the Skyline Collector is configured with a Proxy, the connection to vCenter Server and NSX Manager goes through the configured Proxy. Depending on how the Proxy is configured, the support bundle transfer may fail.
  • The Log Assist upload/download timeout value (previously 3 hours) is now configurable, instead of hardcoded.
  • Utilizing version of esxcli that addresses package vulnerabilities.

Upgrade Instructions

Follow these steps to upgrade to this version of VMware Skyline Collector:

  1. Open a web browser and enter the URL for the Skyline Collector VAMI: https://Skyline_Collector_IP_address_or_FQDN:5480.
  2. Log in using the root username and and password.
  3. Click Login.
  4. Click Update.
  5. Click Check Updates.
  6. If an update is available, click Install Updates.

If Check Updates does not return that an Update is available, verify if your Skyline Collector virtual appliance can access https://vapp-updates.vmware.com over port 443.