When importing vRealize Automation in vRealize Suite Lifecycle Manager, the import fails with an error message.

Problem

If the details of VMware Identity Manager fails to match with vRealize Automation, when importing vRealize Automation in vRealize Suite Lifecycle Manager, you may see the following error message.

Error Code: LCMVRAVACONFIG590026

vRealize Automation Import failed due to VMware Identity Manager details in vRealize Suite Lifecycle Manager not matching with the provided vRealize Automation. Please retry by providing vRealize Automation which has VMware Identity Manager details same as vRSCLM VMware Identity Manager details.

vRA vIDM details mismatch. vRA Import is supported only if vRSLCM vIDM is matched with vRA vIDM details.

Cause

The VMware Identity Manager imported into vRealize Suite Lifecycle Manager does not match the vRealize Automation host that was attempting to import.

Solution

  1. Delete globalenvironment from vRealize Suite Lifecycle Manager. This action is supported in the UI from vRealize Suite Lifecycle Manager version 8.4.
  2. Import VMware Identity Manager which is associated with the vRealize Automation host.
  3. Create a new request to import vRealize Automation.