When upgrading from vCenter Server version 6.0 or earlier, you must prepare your environment before upgrading the Content Library to prevent pre-check errors.

If you are upgrading from vCenter Server version 6.0 or 5.5, your environment must meet upgrade requirements for the Content Library:

  • All ESXi hosts from the source vCenter Server inventory must be supported by the destination vCenter Server 6.5.

  • The source vCenter ServerContent Libraries must be backed by either Remote File System or Datastores. You cannot use libraries backed by local file system of the vCenter Server.

  • All the remote file system shares used as library backings must be accessible at the time of the upgrade.

  • No subscribed libraries are using file based subscription URI.

If you are upgrading from vCenter Server 6.0 Update 1, no actions are necessary.

If your environment does not meet the requirements, you must perform the following actions to prepare for upgrade.