The vSphere Client does not respond to changes in a remote plug-in manifest file.

Problem

After a plug-in fails to deploy due to an invalid plug-in manifest file, the vSphere Client marks it as broken and does not attempt to retry the download even if the plug-in manifest file is later updated on the plug-in server.

Cause

After download the plug-ins are cached locally and a new download will happen if the cached manifest file is deleted. This is expected production workflow. However, development environments require additional configuration to avoid the cached plug-in manifest files.

Solution

Use the Redeploy feature to bypass the plug-in cache during development. For more information, see Redeploying Plug-ins During Development.