Existen varios escenarios en los que el cliente de vSphere Bitfusion no puede conectarse a los servidores de vSphere Bitfusion del clúster.

Problema

Al intentar conectar un cliente de vSphere Bitfusion a los servidores del clúster, se produce un error en la conexión. Normalmente, se muestra un mensaje de error similar al siguiente ejemplo.

Error querying server 10.115.27.120:56001:
Get https://10.115.27.120:56001/query: x509: certificate signed by unknown authority
Unable to contact any of the existing servers: 10.115.27.120:56001

Causa

  • Cuando mueve o clona un cliente de vSphere Bitfusion a una nueva instancia de vCenter Server.
  • Al instalar nuevos servidores de vSphere Bitfusion, lo que da lugar a la creación de un nuevo clúster, y utiliza los clientes de vSphere Bitfusion antiguos.
  • Cuando tiene un servidor de vSphere Bitfusion no válido en el clúster.

Solución

  • Si tiene un servidor de vSphere Bitfusion no válido en el inventario, mediante el complemento de vSphere Bitfusion, quite el servidor del clúster.

    Para obtener más información, consulte Cómo quitar un servidor de vSphere Bitfusion.

    Si el servidor no se puede eliminar del inventario mediante el complemento de vSphere Bitfusion, en el terminal de un servidor de vSphere Bitfusion en ejecución, ejecute el comando bitfusion removenode.

  • Compruebe que se hayan completado todos los pasos durante el proceso de activación del cliente de vSphere Bitfusion.

    Por ejemplo, compruebe que la máquina virtual del cliente de vSphere Bitfusion esté apagada durante el proceso de activación.

    Para obtener más información, consulte Activar el cliente de vSphere Bitfusion en la Instalar VMware vSphere Bitfusion.

  • En el terminal de la máquina virtual del cliente de vSphere Bitfusion, ejecute los siguientes comandos.
    1. rm ~/.bitfusion/client.yaml
    2. rm ~/.bitfusion/servers.conf
    Una vez que se eliminen client.yaml y servers.conf, vuelva a activar el cliente de vSphere Bitfusion.

    Para obtener más información, consulte Activar el cliente de vSphere Bitfusion en la Instalar VMware vSphere Bitfusion.

  • Si ninguno de los pasos anteriores resuelve el problema, cree registros desde un servidor de vSphere Bitfusion y envíe el paquete de soporte al soporte de VMware.

    Para obtener más información, consulte Cómo generar un paquete de soporte desde un servidor de vSphere Bitfusion.