Problème
Horizon 8 Edge est bloqué dans l'état Connexion en attente.
Cause
Le code de couplage n'a pas été fourni lors du déploiement de la passerelle Passerelle Horizon Edge dans VMware vCenter. Le code de couplage est requis pour créer l'espace de noms Kubernetes dans la passerelle Passerelle Horizon Edge qui dispose des modules requis pour marquer le dispositif Edge dans d'autres états (cela peut prendre parfois entre 15 et 20 minutes). Le code de couplage est présent sur le deuxième écran de VMware vCenter, au-dessous du mot de passe racine.
Si le code de couplage est fourni correctement, vérifiez l'appel d'API edge-deployments. L'appel d'API edge-deployments doit être semblable à l'exemple suivant :
admin/v2/edge-deployments/63da2d9216884348cf96a0f5?include_reported_status=true
Pour plus d'informations, reportez-vous à la section https://kb.vmware.com/s/article/92056.
Solution
Assurez-vous que view-cs-module se trouve sous registeredModules et dans , view-cs-module doit être présent et être dans l'état CONNECTED.
Effectuez également les tâches suivantes.
- Assurez-vous que la passerelle Passerelle Horizon Edge est correctement déployée et qu'elle est dans l'état sous tension. En cas de problème de déploiement, vérifiez la mise en réseau, le stockage, etc.
- Utilisez les versions
2.3.1.0
ou ultérieures d'OVA de la passerelle Passerelle Horizon Edge pour spécifier une clé publique pour que l'utilisateurccadmin
se connecte. Les anciennes versions d'OVA présentent un problème lors de l'initialisation de Kubernetes lorsque la clé publique est spécifiée pour l'utilisateurccadmin
. - Exécutez le script de diagnostic en mode de débogage. Pour plus d'informations, reportez-vous à l'article https://kb.vmware.com/s/article/92056. Dans la section Cluster Kubernetes, un espace de noms créé lors de la première mise sous tension de la passerelle Passerelle Horizon Edge doit s'afficher.
- Si ce n'est pas le cas et si l'espace de noms n'est pas créé, cela peut être dû au fait que le réseau n'a pas été configuré correctement à l'étape 2, ou que le code de couplage n'a pas été fourni lors de la création de la passerelle Edge lors du déploiement d'OVA de la passerelle Edge.
Vous pouvez configurer le code de couplage après le déploiement du dispositif de passerelle Passerelle Horizon Edge, s'il n'a pas été fourni lors du déploiement du dispositif de passerelle Passerelle Horizon Edge. Copiez le code de couplage à partir d'Horizon Universal Console et exécutez la commande suivante pour configurer le code de couplage après le déploiement du dispositif de passerelle Passerelle Horizon Edge
/opt/vmware/bin/pair-edge .sh ‘<Pairing_Code_Copied_From_Horizon_Universal_Console>
. - Si l'espace de noms est créé et que le dispositif Edge est toujours bloqué dans l'état En attente de connexion, cela peut être dû à des problèmes de connectivité réseau ou à des URL de cloud inaccessibles à partir du dispositif Edge (cela peut provenir de la configuration du proxy ou d'autres problèmes liés au réseau), voire à la mise à jour de la configuration du proxy dans le dispositif Edge.
- Ensuite, si l'espace de noms est créé, il faut entre 15 et 20 minutes pour que le dispositif Edge s'affiche dans l'état Non configuré, comme indiqué dans l'interface utilisateur ou POST_PROVISIONING_CONFIG_IN_PROGRESS dans l'API. Si cela se produit, vous devriez être en mesure de configurer le Serveur de connexion.
Si cela ne se produit toujours pas, exécutez le script de diagnostic et sous la section Cluster Kubernetes, attendez que l'espace
view-cs-module
soit en cours d'exécution. Exécutez le script de diagnostic en mode de débogage. Pour plus d'informations, reportez-vous à l'article https://kb.vmware.com/s/article/92056.
- Si ce n'est pas le cas et si l'espace de noms n'est pas créé, cela peut être dû au fait que le réseau n'a pas été configuré correctement à l'étape 2, ou que le code de couplage n'a pas été fourni lors de la création de la passerelle Edge lors du déploiement d'OVA de la passerelle Edge.