Vous pouvez mettre à jour VMware Tools manuellement ou vous pouvez configurer les machines virtuelles pour vérifier et installer des versions plus récentes de VMware Tools.

Le système d'exploitation client vérifie la version de VMware Tools à chaque activation de machine virtuelle. La barre d'état de votre machine virtuelle affiche un message lorsqu'une nouvelle version est disponible.

Pour les machines virtuelles vSphere,
Une version plus récente de Tools est disponible pour cette machine virtuelle
s'affiche lorsque la version installée de VMware Tools est obsolète.

Sur les machines virtuelles Windows, vous pouvez définir VMware Tools afin qu'il vous notifie de la publication de mises à niveau. Lorsque cette option est activée, une icône d'avertissement jaune s'affiche sur l'icône de VMware Tools dans la barre des tâches Windows pour signaler qu'une mise à niveau est disponible.

Pour installer une mise à niveau de VMware Tools, vous pouvez suivre la même procédure que celle que vous avez exécutée pour installer VMware Tools la première fois. La mise à niveau de VMware Tools signifie qu'une nouvelle version est installée.

Pour les systèmes d'exploitation clients Windows et Linux, vous pouvez configurer la machine virtuelle pour qu'elle mette automatiquement VMware Tools à niveau. Même si la vérification de version est effectuée lorsque vous mettez la machine virtuelle sous tension, sur les systèmes d'exploitation clients Windows, la mise à niveau automatique s'effectue lorsque vous mettez hors tension ou redémarrez la machine virtuelle. La barre d'état affiche le message Installation de VMware Tools en cours... lorsqu'une mise à niveau est en cours d'installation. La procédure est indiquée ci-dessous.

Note :

La mise à niveau de VMware Tools sur des systèmes d'exploitation clients Windows installe automatiquement les pilotes graphiques WDDM. Le pilote graphique WDDM rend le mode veille disponible dans les paramètres d'alimentation du SE invité pour régler les options de veille. Par exemple, vous pouvez utiliser le paramètre de mode veille Modifier les conditions de mise en veille de l'ordinateur pour configurer votre SE client afin qu'il passe en mode veille automatiquement après un certain temps ou pour empêcher votre SE client de passer automatiquement en mode veille après avoir été inactif pendant un certain temps.

Pour les machines virtuelles vSphere, vous pouvez utiliser l'un des processus suivants pour mettre à niveau plusieurs machines virtuelles en même temps.

  • Connectez-vous à vCenter Server, sélectionnez un hôte ou un cluster et, dans l'onglet Machines virtuelles, spécifiez les machines virtuelles sur lesquelles vous voulez effectuer une mise à niveau de VMware Tools.
  • Utilisez vSphere Lifecycle Manager pour exécuter une mise à niveau orchestrée des machines virtuelles au niveau du dossier ou du centre de données.

Certaines fonctions d'une version donnée d'un produit VMware peuvent dépendre de l'installation ou de la mise à niveau de la version de VMware Tools comprise dans cette version. La mise à niveau de la dernière version de VMware Tools n'est pas toujours nécessaire. Les versions plus récentes de VMware Tools sont compatibles avec plusieurs versions d'hôtes. Afin d'éviter les mises à niveau superflues, évaluez si les fonctions et capacités ajoutées sont nécessaires à votre environnement.

Tableau 1. Options de compatibilité des machines virtuelles
Compatibilité Description
ESXi 7.0 Update 1 et versions ultérieures Cette machine virtuelle (version de matériel 18) est compatible avec ESXi 7.0 Update 1 et versions ultérieures.
ESXi 7.0 et versions ultérieures Cette machine virtuelle (version de matériel 17) est compatible avec ESXi 7.0 et ESXi 7.0 Update 1.
ESXi 6.7 Update 2 et versions ultérieures Cette machine virtuelle (version de matériel 15) est compatible avec ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESXi 6.7 et version ultérieures Cette machine virtuelle (version de matériel 14) est compatible avec ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESXi 6.5 et versions ultérieures Cette machine virtuelle (version de matériel 13) est compatible avec ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESXi 6.0 et versions ultérieures Cette machine virtuelle (version de matériel 11) est compatible avec ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESXi 5.5 et versions ultérieures Cette machine virtuelle (version de matériel 10) est compatible avec ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESXi 5.1 et versions ultérieures Cette machine virtuelle (version de matériel 9) est compatible avec ESXi 5.1, ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESXi 5.0 et versions ultérieures Cette machine virtuelle (version de matériel 8) est compatible avec ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESX/ESXi 4.x et versions ultérieures Cette machine virtuelle (version de matériel 7) est compatible avec ESX/ESXi 4.x, ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1.
ESX/ESXi 3.5 et versions ultérieures Cette machine virtuelle (version de matériel 4) est compatible avec ESX/ESXi 3.5, ESX/ESXi 4.x, ESXi 5.1, ESXi 5.5, ESXi 6.0, ESXi 6.5, ESXi 6.7, ESXi 6.7 Update 2, ESXi 6.7 Update 3, ESXi 7.0 et ESXi 7.0 Update 1. Elle est également compatible avec VMware Server 1.0 et versions ultérieures. ESXi 5.0 ne permet pas la création de machines virtuelles compatibles avec ESX/ESXi 3.5 et versions ultérieures, mais vous pouvez exécuter ces machines virtuelles si elles ont été créées sur un hôte avec une compatibilité différente.

Pour plus d'informations, consultez le Guide de compatibilité de VMware à l'adresse http://www.vmware.com/resources/compatibility.