VMware Aria Automation クラウド アカウントで使用する既存のクラウド プロキシをアップグレードする際に、マニフェストのアクセス エラーを表示して失敗します。

問題

VMware Aria Automation クラウド アカウントが既存および新規のいずれの場合でも、新規のクラウド プロキシを作成および構成せずに、既存の構成済みクラウド プロキシをアップグレードすることは可能です。しかし、アップグレードは次のようなエラー メッセージを表示して失敗することがあります。
Details
Checking for available updates, this process can take a few minutes ...
Failure: Error downloading manifest. Please contact your vendor.  
The requested URL returned error: 404 Not Found URL: <https:// ...>

原因

クラウド プロキシの構成時に使用された /opt/vmware/var/lib/vami/update/provider/provider-runtime.xml マニフェスト ファイルで、アップグレード プロセスに必要な情報が不足している可能性があります。
注: このマニフェスト ファイルの問題は、最近のバージョンの VMware Aria Automation では解決されています。ただし、以前のバージョンのクラウド プロキシを使用している場合に上記のエラー メッセージが表示された場合は、この回避策を使用して、クラウド プロキシの provider-runtime.xml マニフェスト ファイルをアップグレードします。

解決方法

  1. クラウド プロキシのマニフェスト ファイルを探して確認します。/opt/vmware/var/lib/vami/update/provider/provider-runtime.xml の例を次に示します。
    <service>
      <properties>
         <property name="jobId" value="1" />_
         <property name="jobList" value='{ "Check":{ "JobStatus": "Failed", "JobState": 8, "TimeOfLastStateChange": "20210120101111.982008+000", "ErrorCode": 20, "ErrorDescription": "Error downloading manifest. Please contact your vendor. The requested URL returned error: 404 Not Found URL: https:\/\/vapp-updates.vmware.com\/vai-catalog\/valm\/vmw\/a1ba78af-ec67-4333-8e25-a4be022f97c7\/7.2.0.33184.latest\/manifest\/manifest-latest.xml", "TimeBeforeRemoval": "00000000000500.000000:000", "TimeSubmitted": "20210120101031.385064+000", "InstanceID": "VMware-VAMI:Job_1" }}' />_
      </properties>
    </service>
  2. ファイルに上記のような内容が含まれている場合は、ファイルを次の内容に手動で更新します。
    <service>
        <properties>
            <property name="localRepositoryAddress" value="https://ci-data-collector-sandbox.s3.amazonaws.com/upgrade" />
            <property name="localRepositoryPasswordFormat" value="base64" />
        </properties>
    </service>
  3. vCenter 上でクラウド プロキシを再起動します。
  4. 前に実行して上記のエラーが発生したのと同じクラウド プロキシのアップグレード プロセスを実行します。
  5. エラーが続く場合は、VMware サポートに連絡してください。