Horizon Client で USB リダイレクトに関する各種の問題が発生することがあります。

問題

Horizon Client の USB リダイレクトで、ローカル デバイスをリモート デスクトップまたはアプリケーションで使用可能にできなかったり、Horizon Client で一部のデバイスがリダイレクトに使用できるように表示されなかったりします。

原因

USB リダイレクトが正常に機能しなかったり、予期したとおり機能しない場合、次の理由が考えられます。

  • デバイスが複合 USB デバイスであり、含まれるデバイスの 1 つがデフォルトでブロックされています。たとえばマウスを含む読み上げデバイスはデフォルトでブロックされています。これはマウス デバイスがデフォルトでブロックされているためです。この問題を解決するには、複合 USB デバイスのデバイス分割ポリシー設定の構成を参照してください。
  • USB リダイレクトは、公開デスクトップおよびアプリケーションが展開されている Windows Server 2008 RDS ホストではサポートされません。
  • デバイスで USB リダイレクトが正常に機能しないか、デバイスが公開デスクトップおよびアプリケーションでサポートされていません。詳細については、USB デバイス タイプに関する制限事項を参照してください。
  • Web カメラはリダイレクトの対象としてサポートされていません。
  • USB オーディオ デバイスのリダイレクトは、ネットワークの状態に依存し、信頼できません。一部のデバイスでは、アイドル状態のときでさえ、高いデータ スループットが必要です。
  • ブート デバイスでは USB リダイレクトがサポートされていません。USB デバイスからブートする Windows システムで Horizon Client を実行しており、このデバイスをリモート デスクトップにリダイレクトした場合、ローカル オペレーティング システムが応答しなかったり使用できなかったりすることがあります。
  • Horizon Client for Windows では、デフォルトで、キーボード、マウス、スマート カード、オーディオ出力デバイスをリダイレクト対象として選択できません。http://kb.vmware.com/kb/1011600を参照してください。
  • RDP は、コンソール セッションの USB HID またはスマート カード リーダのリダイレクトをサポートしていません。http://kb.vmware.com/kb/1011600を参照してください。
  • Windows Mobile デバイス センターにより、RDP セッションの USB デバイスのリダイレクトが妨げられることがあります。
  • 一部の USB HID では、マウス ポインタの位置を更新するように、仮想マシンを構成する必要があります。
  • 一部のオーディオ デバイスでは、ポリシー設定またはレジストリ設定を変更する必要がある場合があります。
  • ネットワークのレイテンシーが原因で、デバイスの相互作用が低速になったり、アプリケーションがフリーズしているように見えることがあります。これはアプリケーションがローカル デバイスと相互作用するように設計されているからです。非常に大容量の USB ディスク ドライブは、Windows エクスプローラに表示されるまでに数分かかることがあります。
  • FAT32 ファイル システムでフォーマットされた USB フラッシュ カードはロードが遅くなります。http://kb.vmware.com/kb/1022836を参照してください。
  • リモート デスクトップまたはアプリケーションに接続する前に、ローカル システムでプロセスまたはサービスがデバイスを開いていた。
  • リダイレクトされた USB デバイスは、デスクトップまたはアプリケーションにそのデバイスが使用可能であることが表示されている場合でも、デスクトップまたはアプリケーション セッションを再接続すると、動作が停止します。
  • Horizon Administrator で USB リダイレクトが無効になっている。
  • ゲスト上で、USB リダイレクト ドライバが存在しないか、無効になっている。

解決方法

  • VMware Blast または PCoIP が使用可能な場合は、RDP の代わりにプロトコルとして使用します。
  • 一時的な切断後に、リダイレクトされたデバイスが使用できないままであるか、動作を停止した場合、デバイスを取り外し、再度接続して、リダイレクトを再試行してください。
  • Horizon Administrator で、[ポリシー] > [グローバル ポリシー] の順に移動して、[View ポリシー] で USB アクセスが [許可] に設定されていることを確認します。
  • ゲストのログでクラス ws_vhub のエントリの有無、クライアントのログでクラス vmware-view-usbd のエントリの有無を調べます。
    ユーザーが管理者でない場合、または USB リダイレクト ドライバがインストールされていないか、機能していない場合には、これらのクラスのエントリがログに書き込まれます。これらのログの場所については、 ログ ファイルを使用してのトラブルシューティングと USB デバイス ID の確認を参照してください。
  • ゲスト上でデバイス マネージャを開き、[ユニバーサル シリアル バス コントローラ] を展開して、VMware View 仮想 USB ホスト コントローラのドライバおよび VMware View 仮想 USB ハブのドライバが表示されない場合はそれらを再インストールし、無効になっている場合は再度有効にします。