VMware Host Client でデータストアをアンマウントすると、そのデータストアの状態は変更されませんが、管理対象ホストのインベントリには表示されなくなります。マウントされたままの状態になっている別のホストでは、データストアは引き続き表示されます。
前提条件
- そのデータストア上に仮想マシンが存在しない。
- Storage DRS は、データストアを管理していない。
- そのデータストアに対して Storage I/O Control が無効になっている。
手順
- VMware Host Client インベントリ内で [ストレージ] > [データストア] の順にクリックします。
- リスト内でアンマウントするデータストアを右クリックし、[アンマウント] をクリックします。
- データストアをアンマウントすることを確認します。
データストアのアンマウントまたは削除の失敗
データストアをアンマウントまたは削除しようとすると、操作が失敗します。
問題
データストアでファイルが開かれている場合、データストアをアンマウントまたは削除する操作は失敗します。このようなユーザー操作では、vSphere HA エージェントは開いているすべてのファイル、たとえばハートビート ファイルを閉じます。vCenter Server がエージェントにアクセスできない、またはエージェントが保留中の I/O をフラッシュしてファイルを閉じることができない場合、「ホスト「{hostName}」の HA エージェントは、データストア「{dsName}」でのファイル アクティビティの静止に失敗しました」という障害が発生します。
原因
アンマウントまたは削除するデータストアがハートビートに使用されている場合、vCenter Server はデータストアをハートビートから除外し、新しいデータストアを選択します。ただし、アクセスできない、つまり、ホストが隔離されているまたはネットワーク パーティション分割されている場合、エージェントは更新されたハートビート データストアを取得しません。このような場合、ハートビート ファイルは閉じられず、ユーザーの操作は失敗します。操作は、all paths down 状態などのストレージ障害が原因でデータストアがアクセス不可能である場合も失敗する可能性があります。
解決方法
データストアがアクセス可能で、影響を受けるホストにアクセスできることを確認します。