vRealize Business for Cloud は vCenter Server のデータを収集できません。
問題
vRealize Business for Cloud のユーザー インターフェイスで [ステータス] をクリックすると、次に挙げる問題のいずれかが発生します。
- vCenter Server のステータスに赤いアイコンが表示される。
- vCenter Server の同期失敗メッセージが表示される。
- vCenter Server のセクションに次のエラー メッセージが表示される。
Unable to retrieve data from vROps vrops_server_address
- vRealize Business for Cloud のユーザー インターフェイスで [ステータス] をクリックすると、vCenter Server に次のエラー メッセージが表示されます。
Unable to authenticate to vROps vrops_server_address using the vCenter's credentials
原因
この問題は、次のいずれかの状況が原因で発生する可能性があります。
- vRealize Business for Cloud 仮想アプライアンスのタイムゾーンが UTC 形式ではない。
- 同じ LocalSystem アカウントまたはドメイン アカウントで、vCenter Server、Web サービスおよびプロファイル ベースのサービスが実行されていない。
- vRealize Operations Manager サーバにアクセスできない。
- vRealize Operations Manager API サービスに障害がある。
- vRealize Operations Manager サーバが HA クラスタ化されたマルチノード環境上にあり、vCenter Server で登録されたノードにアクセスできない。
- vCenter Server の個別ユーザー ログインが vRealize Operations Manager で無効になっている。
解決方法
詳細については、http://kb.vmware.com/kb/2146836でナレッジベースの記事を参照してください。
手順
- この問題を解決するには、次の解決策から該当する手順を実行します。
- vRealize Business for Cloud 仮想マシンでタイム ゾーンを UTC 形式に変更します。その後、
monit restart itbm-server
コマンドを実行します。 - インベントリ、統計情報、およびストレージ プロファイルなど、すべての vCenter Server サービスが同じアカウントで実行されていることを確認します。
- vCenter Server が過去 24 時間以内に vRealize Operations Manager に追加されている場合は、 vRealize Operations Manager がすべてのデータの計算を完了するまで待ってから、再度データ収集を実行してください。
- vRealize Operations Manager API サービスに問題がないかを確認し、あれば解決してください。
- vRealize Operations Manager インスタンスがマルチノードの設定である場合、および障害の発生したノードを置き換えるために新しいノードがデプロイされた場合は、 vRealize Operations Manager でプラグインを更新して、新しいノードを vCenter Server に登録します。
- vRealize Operations Manager インスタンスの個別のログイン オプションを有効にします。
の順にクリックします。
- vRealize Business for Cloud 仮想マシンでタイム ゾーンを UTC 形式に変更します。その後、