vCenter Single Sign-On 설치 시 vCenter Server 또는 vSphere Client나 vSphere Web Client를 나타내는 오류가 표시됩니다.
문제
vCenter Server 및 Web Client 설치 관리자에 Could not contact Lookup Service. Please check VM_ssoreg.log...
오류가 표시됩니다.
원인
이 문제의 원인은 호스트 시스템의 클럭이 동기화되지 않았거나, 방화벽이 차단하고 있거나, 서비스를 시작해야 하는 등 여러 가지입니다.
해결책
- vCenter Single Sign-On, vCenter Server 및 Web Client를 실행하는 호스트 시스템의 클럭이 동기화되었는지 확인합니다.
- 오류 메시지에 나와 있는 특정 로그 파일을 확인합니다.
오류 메시지에서 시스템 임시 폴더는
%TEMP%를 의미합니다.
- 해당 로그 파일 내에서 다음과 같은 오류 메시지를 검색합니다.
로그 파일에는 모든 설치 시도에 대한 출력 메시지가 포함되어 있습니다.
Initializing registration provider...
이 표시된 마지막 메시지를 찾습니다.
메시지 |
원인 및 해결 방법 |
java.net.ConnectException: Connection timed out: connect |
IP 주소가 잘못되었거나, 방화벽이 vCenter Single Sign-On으로의 액세스를 차단하고 있거나, vCenter Single Sign-On이 오버로드된 경우입니다. 방화벽에 의해 vCenter Single Sign-On 포트(기본값: 7444)가 차단되고 있지 않은지 확인합니다. 또한 vCenter Single Sign-On이 설치되어 있는 시스템에 사용 가능한 CPU, I/O 및 RAM 용량이 충분한지 확인합니다. |
java.net.ConnectException: Connection refused: connect |
IP 주소 또는 FQDN이 잘못되었고 vCenter Single Sign-On 서비스가 아직 시작되지 않았거나, 시작된 지 1분이 지나지 않은 경우입니다. vCenter Single Sign-On 서비스(Windows) 및 vmware-sso 데몬(Linux)의 상태를 확인하여 vCenter Single Sign-On이 작동 중인지 확인합니다. 서비스를 다시 시작합니다. 다시 시작으로 문제를 해결할 수 없으면 "vSphere 문제 해결 가이드" 의 복구 섹션을 참조하십시오. |
Unexpected status code: 404. SSO Server failed during initialization |
vCenter Single Sign-On을 다시 시작합니다. 다시 시작으로 문제를 해결할 수 없으면 "vSphere 문제 해결 가이드" 의 복구 섹션을 참조하십시오. |
UI에 나와 있는 오류가 Could not connect to vCenter Single Sign-On 로 시작하는 경우입니다. |
또한 SslHandshakeFailed라는 반환 코드도 표시됩니다. vCenter Single Sign-On 호스트로 확인되는, 지정된 IP 주소나 FQDN이 vCenter Single Sign-ON을 설치할 때 사용한 주소와 다르다는 것을 나타냅니다. %TEMP%\VM_ssoreg.log에서 다음 메시지가 포함된 줄을 찾습니다. host name in certificate did not match: <install-configured FQDN or IP> != <A> or <B> or <C> 여기서 A는 vCenter Single Sign-On을 설치할 때 입력한 FQDN이며, B와 C는 시스템에서 대신 사용할 수 있게 생성된 FQDN입니다.
로그 파일에서 != 기호의 오른쪽에 나와 있는 FQDN을 사용하도록 구성을 수정합니다. 대부분의 경우 vCenter Single Sign-On 설치 시 지정한 FQDN을 사용합니다. 사용할 수 있는 대체 FQDN이 네트워크 구성에 없는 경우에는 vCenter Single Sign-On SSL 구성을 복구해야 합니다. |