大規模な Site Recovery Manager 環境で、共有リカバリ サイトの仮想マシンをパワーオンする際にタイムアウト エラーが発生することがあります。

問題

共有リカバリ サイトの仮想マシンをパワーオンすると、「エラー:操作はタイムアウトしました:900 秒」というエラー メッセージが表示されます。

原因

この問題は、単一の vCenter Server インスタンスが共有リカバリ サイトで多数の仮想マシン(たとえば 1000 以上)を管理する場合に発生することがあります。

解決方法

  1. リカバリ サイトの Site Recovery Manager ServerremoteManager.defaultTimeout タイムアウト値を増やします。
    たとえば、タイムアウトをデフォルトの 300 秒から 1200 秒に増やします。 remoteManager.defaultTimeout 設定の増やし方についての詳細は、『 Site Recovery Manager 管理』の「 リモート マネージャ設定の変更」を参照してください。

    タイムアウト期間を極端に大きくしないでください。タイムアウトを非常に長い値に設定すると、Site Recovery Manager ServervCenter Server または Site Recovery Manager が必要とするその他のサービスとの間の通信に関する問題などが判明しづらくなることがあります。

  2. テキスト エディタで vmware-dr.xml ファイルを開きます。
    vmware-dr.xml ファイルは /opt/vmware/srm/conf/ ディレクトリにあります。
  3. vSphere Client から読み取る場合のタイムアウトを設定します。
    <vmacore><http> 要素に 1 行を追加して、タイムアウトを 900 秒(15 分)に設定します。
    <vmacore>
      <http>
        <defaultClientReadTimeoutSeconds>900</defaultClientReadTimeoutSeconds>
      </http>
    </vmacore>
  4. Site Recovery Manager Server サービスを再起動します。

次のタスク

RemoteManager タイムアウト値を増やした後も引き続きタイムアウトが発生する場合は、段階的に長いタイムアウトの設定を試してみます。