vSphere Bitfusion クライアントがクラスタ内の vSphere Bitfusion サーバに接続できない状況がいくつかあります。
問題
vSphere Bitfusion クライアントをクラスタ内のサーバに接続しようとすると、接続に失敗します。通常、次の例のようなエラー メッセージが表示されます。
Error querying server 10.115.27.120:56001: Get https://10.115.27.120:56001/query: x509: certificate signed by unknown authority Unable to contact any of the existing servers: 10.115.27.120:56001
原因
- vSphere Bitfusion クライアントを新しい vCenter Server インスタンスに移動またはクローン作成している場合。
- 新しい vSphere Bitfusion サーバをインストールして新しいクラスタが作成されたときに、古い vSphere Bitfusion クライアントを使用した場合。
- クラスタ内に無効な vSphere Bitfusion サーバがある場合。
解決方法
- インベントリ内に無効な vSphere Bitfusion サーバがある場合は、vSphere Bitfusion プラグインを使用して、そのサーバをクラスタから削除します。
詳細については、『vSphere Bitfusion サーバを削除する方法』を参照してください。
vSphere Bitfusion プラグインを使用してインベントリからサーバを削除できない場合は、実行中の vSphere Bitfusion サーバのターミナルで
bitfusion removenode
コマンドを実行します。 - vSphere Bitfusion クライアントの有効化プロセスですべての手順が完了していることを確認します。
たとえば、有効化プロセスで vSphere Bitfusion クライアントの仮想マシンがパワーオフされていることを確認します。
詳細については、『VMware vSphere Bitfusion のインストール』の「vSphere Bitfusion クライアントの有効化」を参照してください。
- vSphere Bitfusion クライアントの仮想マシンのターミナルで、次のコマンドを実行します。
rm ~/.bitfusion/client.yaml
rm ~/.bitfusion/servers.conf
詳細については、『VMware vSphere Bitfusion のインストール』の「vSphere Bitfusion クライアントの有効化」を参照してください。
- 前の手順で問題が解決しない場合は、vSphere Bitfusion サーバからログを作成し、VMware のサポートにサポート バンドルを送信します。
詳細については、『vSphere Bitfusion サーバからサポート バンドルを生成する方法』を参照してください。